Prime+ 2.0 Service Disruption

Incident Report for Lumos Data Service Status

Resolved

The third-party outage has been fully resolved, and system operations have returned to normal. An update on the cause of the outage will be issued within the next few days.
Posted Oct 27, 2025 - 18:15 EDT

Monitoring

A fix is rolling out across all AWS regions, and our provider is reporting early signs of recovery. We’re continuing to monitor and will confirm once Lumos services are fully restored.
Posted Oct 27, 2025 - 17:21 EDT

Identified

We have identified the root cause of the ongoing service disruption. The issue stems from an outage impacting one of our cloud & data warehouse service providers. This is currently affecting critical parts of our infrastructure and resulting in errors.

Our team is actively monitoring the situation and working to mitigate the impact where possible.

We’ll continue to provide updates as we learn more.
Posted Oct 27, 2025 - 13:39 EDT

Investigating

We are currently investigating an issue affecting parts of our production system. This may result in intermittent errors for some users.

Our engineering team is actively working to resolve the issue and restore full functionality as quickly as possible.
Posted Oct 27, 2025 - 13:04 EDT
This incident affected: Portal Products (PRIME+ UI) and APIs (Prime+ 2.0 Model).