Degraded Performance Due to Third Party Outage

Incident Report for Lumos Data Service Status

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 14:33 EDT

Investigating

We are currently experiencing extended dashboard load times due to a third party outage.

If you need immediate assistance or access please do not hesitate to reach out to support@lumosdata.com.
Posted Oct 30, 2025 - 14:23 EDT
This incident affected: Portal Products (Insights Visualizations, LBR (Lumos Business Report)).