System are back up but given that the downstream vendor (AWS) is still recovering we will keep this incident open and continue to actively monitor to ensure full recovery.
Posted May 07, 2026 - 23:06 EDT
Identified
Scoring API are being impacted by degraded performances of a downstream vendor causing our service to return 500 error. We are monitoring the situation and will update as soon as we know more.
Posted May 07, 2026 - 21:16 EDT
This incident affected: Portal Products (LBR (Lumos Business Report), PRIME+ UI) and APIs (Qualification Grade Credit Model, Prime+ 2.0 Model).